ANNEX32_1.43: autorefresh fails

Here we can discuss about the problem found
Post Reply
User avatar
PeterN
Posts: 97
Joined: Mon Feb 08, 2021 7:56 pm
Location: Krefeld, Germany
Has thanked: 41 times
Been thanked: 45 times
Contact:

ANNEX32_1.43: autorefresh fails

Post by PeterN »

Hi CiccioCB,

I did an update of my ESP32-WordClock towards ANNEX32 1.43
It seems to me that autorefresh now has a problem.
I tested it with the following code and expected a refresh every 2 seconds.
But this only works if I uncomment the refresh in SET_TIME:

Am I overseeing something?

Code: [Local Link Removed for Guests]

'AUTOREFRESH TEST 

'autorefresh seems to fail in ANNEX32 1.43 CAN BLE 
' This code works in prior version
text$ = "Start"
CLS
HTML TEXTBOX$(text$)
autorefresh 2000  'should update HTML every 2 seconds 
timer0 1000, SET_TEXT
Wait     

SET_TEXT:
text$ = time$
'refresh   'updates HTML every 1 second  if not commented
Return

END 
cicciocb
Site Admin
Posts: 309
Joined: Mon Feb 03, 2020 1:15 pm
Location: Toulouse
Has thanked: 85 times
Been thanked: 197 times
Contact:

Re: ANNEX32_1.43: autorefresh fails

Post by cicciocb »

Good catch Peter, you are right.
I'm doing the fix and I'll post an updated release.
cicciocb
Site Admin
Posts: 309
Joined: Mon Feb 03, 2020 1:15 pm
Location: Toulouse
Has thanked: 85 times
Been thanked: 197 times
Contact:

Re: ANNEX32_1.43: autorefresh fails

Post by cicciocb »

I just uploaded another version for both ESP32 and CAMERA.

This version fixes the problem with the AUTOREFRESH

cicciocb
User avatar
PeterN
Posts: 97
Joined: Mon Feb 08, 2021 7:56 pm
Location: Krefeld, Germany
Has thanked: 41 times
Been thanked: 45 times
Contact:

Re: ANNEX32_1.43: autorefresh fails

Post by PeterN »

YOU ARE FASTER THAN LIGHTNING!
THANKS!
Post Reply